Sign Up for Free

RunKit +

Try any Node.js package right in your browser

This is a playground to test code. It runs a full Node.js environment and already has all of npm’s 400,000 packages pre-installed, including flexcarouseljs with all npm packages installed. Try it out:

flexcarouseljs lists no main file and has no index.js, so it can't be directly required. If this is a mistake, please let us know. It may however contain internal files that you can require manually:

// require("flexcarouseljs/[??]")

This service is provided by RunKit and is not affiliated with npm, Inc or the package authors.

flexcarouseljs v1.0.0

A simple, lightweight Flexbox carousel JavaScript plugin.

flexCarousel.js

A simple, lightweight Flexbox carousel ES6 JavaScript plugin. An unofficial fork of Slick Carousel.

Status

npm version CSS gzip size JS gzip size downloads Netlify Status

Getting Started

Compatibility

flexCarousel.js supports the latest, stable releases of all major browsers except Internet Explorer.

We build the carousels using Flexbox browser technology and ES6 syntax which is compiled to ES5 for production-ready code. You can find browser compatibility statistics for both Flexbox and ES5 on Can I use....

However, for a quick overview - read the table below which shows you the browser support for flexCarousel.js. All browser tests are conducted with Browser Stack.

Edge
Microsoft Edge
Firefox
Mozilla Firefox
Chrome
Google Chrome
Safari
Safari
Opera
Opera
>=16>=52>=55>=11.1>=42

Contributing

Feel free to submit a pull request with any changes that will help make this project better!

RunKit is a free, in-browser JavaScript dev environment for prototyping Node.js code, with every npm package installed. Sign up to share your code.
Sign Up for Free