Sign Up for Free

RunKit +

Try any Node.js package right in your browser

This is a playground to test code. It runs a full Node.js environment and already has all of npm’s 1,000,000+ packages pre-installed, including metro4 with all npm packages installed. Try it out:

var metro4 = require("metro4")

This service is provided by RunKit and is not affiliated with npm, Inc or the package authors.

metro4 v4.4.0

The front-end framework for Build responsive, mobile-first projects on the web with the first front-end component library in Metro Style

Metro 4 Components Library

Sleek, intuitive, and powerful front-end framework for faster and easier web development. Build responsive, mobile-first projects on the web with the first front-end component library in Metro Style.
Explore Metro 4 docs »

Metro 4 is an MIT-licensed open source project. It's an independent project with its ongoing development made possible entirely thanks to the support by these
awesome Backers.



Build Status Dependencies CSS gzip size JS gzip size Icons gzip size GitHub release npm version Nuget Website xscode License: MIT GitHub issues GitHub code size in bytes


Current version 4.4.0

License and Premium Features

dual license

As of version 4.4.0, this project licensed under the GPLv3 license. An MIT licensed version is available for an annual subscription here and for a Patreon Patrons.

Subscribers will get access to special Metro 4 repo with MIT license.
Patreon Patrons get access to dedicated email support.

Donation on Patreon

Donations on Patreon Donations on Patreon

Community

Join the chat at https://discord.gg/NydRab3 Join the chat at https://gitter.im/metro4/Lobby

Contributing

All contributions are welcome. Learn more about how you can contribute to this project here.

Docs

Please click here for Documentation and Demo.

Releases

Metro 4 releases frequently. I Am create release when there are significant bug fixes, new APIs or components. The usual frequency of release of the new version is one week on Sundays.

LTS

Long term support of older versions of Metro 4 does not currently exist. If your current version of Metro 4 works for you, you can stay on it for as long as you'd like. If you want to make use of new features as they come in you should upgrade to a newer version.

Browser Compatibility

ChromeFirefoxEdgeIESafariOpera
Latest ✔Latest ✔Latest ✔11+ ✔9.1+ ✔Latest ✔

Old version

Metro UI CSS 3.x you can find in a repo Metro-UI-CSS-3
Metro UI CSS 2.x you can find in a repo Metro-UI-CSS-2
Metro UI CSS 0.x you can find in a repo Metro-UI-CSS-095

Documentation and Demo for V3: metroui.org.ua/v3.
Documentation and Demo for V2: metroui.org.ua/v2.
Documentation and Demo for V0: metroui.org.ua/v0.

Thanks

Thanks to all. Special thanks to all those who financially supported the project.

Credits

You can read about credits here


2012-2020 © Copyright by Serhii Pimenov. All Rights Reserved. Created by Serhii Pimenov.

Metadata

RunKit is a free, in-browser JavaScript dev environment for prototyping Node.js code, with every npm package installed. Sign up to share your code.
Sign Up for Free